RIP 路由配置实验脚本

RIP 路由配置实验

一、实验拓扑
在这里插入图片描述

二、实验配置过程
(1)路由器基本配置
1、路由器R1的基本配置
ZXR10(config)#hostname cgt01
Cgt01(config)#interface gei-2/1
Cgt01(config-if)#ip address 10.51.1.1 255.255.255.252
Cgt01(config-if)#no shutdown
Cgt01(config-if)#exit
Cgt01(config)#interface loopback1
Cgt01(config-if)#ip address 10.51.2.1 255.255.255.255
Cgt01(config-if)#no shutdown
Cgt01(config-if)#exit
2,路由器R2的基本配置
ZXR10(config)#hostname cgt02
Cgt02(config)#interface gei-2/1
Cgt02(config-if)#ip address 10.51.1.2 255.255.255.252
Cgt02(config-if)#no shutdown
Cgt02(config-if)#exit
Cgt02(config)#interface loopback1
Cgt02(config-if)#ip address 10.51.2.2 255.255.255.255
Cgt02(config-if)#no shutdown
Cgt02(config-if)exit
(2)RIP路由的基本配置
1、路由器R1的配置
Cgt01(config)#router rip
Cgt01(config-router)#network 10.51.2.1 0.0.0.0
Cgt01(config-router)#network 10.51.1.0 0.0.0.3
Cgt02(config-router)#network 10.51.3.1 0.0.0.255
Cgt01(config-router)#version 2
Cgt01(config-router)# no auto-summary
2、路由器R2的配置
Cgt02(config)#router rip
Cgt02(config-router)#network 10.51.2.2 0.0.0.0
Cgt02(config-router)#network 10.51.1.0 0.0.0.3
Cgt02(config-router)#network 10.51.4.1 0.0.0.255
Cgt02(config-router)#version 2
Cgt02(config-router)# no auto-summary
验证命令:
show run 查看全局配置
show ip int bri 查看简要接口信息 是否激活 ip地址对与不对
show ip router 查看路由表信息 有没有没宣告的 没学习到的
二、路由表信息(预测)
Dest Mask Getway Interface Owner Pri Metric
10.51.1.0 255.255.255.252 10.51.1.1 gei_2/1 direct 0 0
10.51.1.1 255.255.255.255 10.51.1.2 gei_2/1 address 0 0
10.51.2.1 255.255.255.255 10.51.2.1 Loopback1 direct 0 0
10.51.2.1 255.255.255.255 10.51.2.1 Loopback1 address 0 0
10.51.3.1 255.255.255.255 10.51.1.2 gei_2/1 rip 120 2
10.51.3.0 255.255.255.0 10.51.3.1 gei_2/1 direct 0 0
10.51.4.0 255.255.255.0 10.51.4.1 gei_2/1 rip 120 1

已标记关键词 清除标记
相关推荐